New to AlexFTPS put command

Aug 10, 2010 at 7:55 PM
Edited Aug 10, 2010 at 8:21 PM

I am getting the following message when I try and put a file to an ftp server. " ERROR: Value cannot be null. Parameter name: input

Here is my command:

ftps -h 192.168.1.100 -U username -P password -port  990 -ssl ALL -p test.txt

the test.txt file is in the same directory as the ftps.exe file.

I think the problem is with my path after the -p command but im not sure..

 

thanks, Macomb

Coordinator
Aug 10, 2010 at 8:16 PM

Hi Macomb,

the command line itself looks correct, the error comes from the server side.

A note which might help: port 990 is usually related to "implicit" FTPS, a non standard FTP extension supported with the "-ssl Implicit" command line option.

All other -ssl option values are related to "explicit" FTPS.

 

Cheers,

Alessandro Pilotti

[MVP / IIS]

 

 

 

 

Aug 10, 2010 at 8:38 PM

thanks for the input. here is where I am now.

 

Ive changed the -sll ALL to -sll implicit and it seems like something just isnt talking correctly. I get a message about unable to read data from transport connection.

then when I look at the txt file that was transfered it has a bunch of unknown characters in it.

 

ps Ive talked to the admin of the ftps server and he wasnt much help. :-(

 

thanks for any input.. -Macomb