ftps fails with ip v6 enabled

Feb 25, 2011 at 2:32 PM

Hello, Using the ftps.exe command and I have noticed that it will fail while connecting to a Windows 2008R2 ftps site if using ipv6.

While we are not really using ipv6 the tunnel adaptors are enabled by default and registered in dynamic dns.

Get the message: ERROR: 'PASV ': command not understood. Use EPSV command.

If I try the same host with ipv4 address it works fine.

Coordinator
Mar 2, 2011 at 10:32 PM

Hi,

IPV6 support is not yet implemented. See Todo section in the homepage.

It will be included in the next release.

 

Kind regards,

Alessandro Pilotti

[ MVP / IIS ]

Mar 3, 2011 at 12:01 AM

Is there anyway to force a V4 connection when using a host that has both V4 and V6 enabled?

Coordinator
Mar 3, 2011 at 3:53 PM

Hi,

did u try to connect providing an IPv4 address instead of the name? 

Mar 3, 2011 at 5:04 PM

Yes, That does work, but using the dns name would be ideal.

From: alexp [email removed]
Sent: Thursday, March 03, 2011 11:54 AM
To: Josuweit, Samuel
Subject: Re: ftps fails with ip v6 enabled [ftps:247576]

From: alexp

Hi,

did u try to connect providing an IPv4 address instead of the name?

Coordinator
Mar 3, 2011 at 5:12 PM

Hi,

in that case unfortunately you have to resolve your name to an IPv4 address or wait for IPv6 support, there's no other option :-)

MS ftp service answer in base of the connecting address type, which means that an IPv6 address requires EPSV support.

 

Regards,

Alessandro Pilotti

[ MVP / IIS ]