This project is read-only.

OPTS UTF8 ON: command not understood

Jul 2, 2009 at 6:01 PM

I have just downloaded AlexFTPS client and installed it on my XP Pro SP2 system and was trying to list files on one of our servers. I issued the command:

C:\Documents and Settings\whenning>ftps -h hostname -noCopyrightInfo -port 8021 -ssl ALL -U username -password password -l -sslInvalidServerCertHandling Accept


I get the following errors and the session is terminated.

WARNING: SSL/TLS remote certificate chain errors

ERROR: 'OPTS UTF8 ON': command not understood.

Can you give me some pointers on how to correct this?

Jul 2, 2009 at 6:17 PM


it seems that your server does not understand the OPT UTF8 ON command properly.

Could you please tell me the product name and version of your FTP server?


Here's a custom build which ignores the UTF8 response (already committed to the source tree):

Please let me know if it works, in order to include it with the next release.








Jul 6, 2009 at 2:26 PM


That solved the problem. We are using Tumbleweed software version 4.8.1



Jul 28, 2015 at 2:35 PM
Edited Jul 28, 2015 at 2:49 PM
Receiving the same error but through the .NET class library.

The server I am connecting to does not support OPTS, I do not have control of this server so need to be able to turn off OPTS in my request from the class library. Please could you explain how to do this?

The .NET code I am using:
using (FTPSClient client = new FTPSClient())
    client.Connect(host, credentials, ESSLSupportMode.ClearText);


In addition, the custom build you have provided has a broken link.
Aug 18, 2015 at 3:36 PM
I'm also hitting this problem against a Secure Transport 5.2.1 FTP server over which I have no control.

Would it be possible to check that the OPTS command is supported before calling SetTextEncoding(ETextEncoding.UTF8) in FTPSClient.cs?